Error "Cannot add a reserve key if the corresponding license expired before the current license”
Issue
Errors may occur during the activation of Kaspersky Endpoint Security for Windows (KESW).
The error "Cannot add a reserve key if the corresponding license expired before the current license" may occur when trying to add a new license.
Cause
A new license expires earlier than the current active license.
Solution
- Clear the Automatically distributed license key check box in the properties of the current active license on the Administration Server so it doesn’t get applied again.
- Add a new license via the Administration Server or via the local Kaspersky Endpoint Security for Windows interface.
How to add a new license via the Administration Server
- Create the Add key task.
- Specify a new license key.
- Clear the Use as a reserve key check box when adding the key.
How to add a new license via the local Kaspersky Endpoint Security for Windows interface
- Go to the Licenses section and remove the current active license key.
- Click Activate the application using a new license and add a new license key.
What to do if the issue persists
- Centrally remove the active license on the managed devices and distribute the new license:
- Change the KESW administration password to a temporary password while the license removal task is performed.
- Create a new BAT file.
- In the file, specify the license removal parameters for the command line. For devices with an activation problem, specify the path to the avp.com file if it was not added to a system variable when KESW was installed.
Example of the file contents for removing the active Kaspersky Endpoint Detection and Response Add-on license key on two devices with different KESW versions and operating system architectures:"%ProgramFiles(x86)%\Kaspersky Lab\KES.12.6.0\avp.com" LICENSE /DEL EDR /login=KLAdmin /password=TempPassword!123
"%ProgramFiles%\Kaspersky Lab\KES.12.3.0\avp.com" LICENSE /DEL EDR /login=KLAdmin /password=TempPassword!123 - Create a custom installation package with the created BAT file.
- Install this package on the devices with the activation problem.
- Replace the temporary KESW protection password with a permanent one.
- Distribute the new license key.
- If the issue persists, perform the steps below one by one and check the result after each step:
- Restart the operating system on the device with the activation problem.
- Reissue the license key file and use it to activate KESW.
- Reinstall KESW on the devices with the activation problem.
- Install the latest cumulative patch.
- Install the latest KESW version.
- Install the latest cumulative patch for the latest KESW version.
You can also find answers to other questions about licensing in the Answers to frequently asked questions.
If the issue persists, collect diagnostic data and submit a request to Kaspersky Technical Support via Kaspersky CompanyAccount. Also attach the Kaspersky Endpoint Security for Windows trace files and a report from the Administration Server about the use of the license keys.