Kaspersky Security Center
 
 

Issues when installing or removing the Kaspersky Security Center Network Agent

Latest update: 3 May 2024 ID: 16032
 
 
 
 
Show applications and versions that this article concerns
  • Kaspersky Security Center 14.2 (version 14.2.0.26967)
  • Kaspersky Security Center 14 (version 14.0.0.10902)
  • Kaspersky Security Center 13.2 (version 13.2.0.1511)
  • Kaspersky Security Center 13.1 (version 13.1.0.8324)
  • Kaspersky Security Center 13 (version 13.0.0.11247)
 
 
 
 
Do not use the recommendations from the article for the Administration Server. The instructions are only for managed devices with problems installing or removing the Network Agent.

Issue

When installing the Network Agent, the system errors may occur:

  • “Error 25003. System error 0x1F (A device attached to the system is not functioning.)”.
  • “Error (System error 0x80090006 (Invalid Signature.))”.
  • “(1192/0x0 ("System container 'LOC-PUB-6EEB50F8D2EB46029DB4CCB77E0DA651' is corrupt")”.

Installing the Kaspersky Security Center Network Agent or removing the application may result in other errors. However, using the cleaner utility to remove the previously installed versions of the Network Agent does not fix the error.

Cause

  • The Protected Storage of the device's operating system is corrupted. This affects the Network Agent installation wizard.
  • The installed version of the Network Agent is not compatible with the device's operating system.
  • There are files and records remaining from previous installations of the application that prevent it from being installed or removed.

Solution

If the problem is related to the damaged Windows Protected Storage on the device, restore it using the instructions.

 
 
 
 

How to restore the Protected Storage

 
 
 
 

What to do if the issue persists

 
 
 
 
 
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