Issues when installing or removing the Kaspersky Security Center Network Agent
Show applications and versions that this article concerns
- Kaspersky Security Center 14.2 (version 14.2.0.26967)
- Kaspersky Security Center 14 (version 14.0.0.10902)
- Kaspersky Security Center 13.2 (version 13.2.0.1511)
- Kaspersky Security Center 13.1 (version 13.1.0.8324)
- Kaspersky Security Center 13 (version 13.0.0.11247)
Issue
When installing the Network Agent, the system errors may occur:
- “Error 25003. System error 0x1F (A device attached to the system is not functioning.)”.
- “Error (System error 0x80090006 (Invalid Signature.))”.
- “(1192/0x0 ("System container 'LOC-PUB-6EEB50F8D2EB46029DB4CCB77E0DA651' is corrupt")”.
Installing the Kaspersky Security Center Network Agent or removing the application may result in other errors. However, using the cleaner utility to remove the previously installed versions of the Network Agent does not fix the error.
Cause
- The Protected Storage of the device's operating system is corrupted. This affects the Network Agent installation wizard.
- The installed version of the Network Agent is not compatible with the device's operating system.
- There are files and records remaining from previous installations of the application that prevent it from being installed or removed.
Solution
If the problem is related to the damaged Windows Protected Storage on the device, restore it using the instructions.
- Check whether the Network Agent supports your operating system.
- If the problem is caused by files or records from the previous installations, collect the diagnostic information and submit a request to Technical Support.
How to restore the Protected Storage
- Open the command line as an administrator and run this command to search for the Network Agent keys in the Protected Storage folder:
- Restart the device and install the Network Agent.
If the issue persists:- Restore the Windows image using the commands:
DISM.exe /Online /Cleanup-image /Scanhealth
DISM.exe /Online /Cleanup-image /Restorehealth
sfc /scannow - Restart the device and reinstall the Network Agent.
- Restore the Windows image using the commands:
If the Network Agent keys are detected, manually delete them from the Storage folder: %ProgramData%\Microsoft\Crypto\RSA\MachineKeys
If the system errors persist, reinstall the Windows operating system or contact Microsoft technical support.
What to do if the issue persists
Submit a request to Technical Support through Kaspersky CompanyAccount.
Please describe the problem in detail and attach:
- Screenshots of errors.
- The GetSystemInfo report with operating system events from the target device that doesn’t connect to the Network Agent.
- Installation logs of the Network Agent.
- The exported registry branches (see the instructions):
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Installer\
HKEY_CLASSES_ROOT\Installer\Products\