Errors “Unexpected error occurred” and “Address family not supported by protocol” when installing Kaspersky Secure Mail Gateway
Issue
After entering the IP address and port, the initial configuration of Kaspersky Secure Mail Gateway in Linux terminates with the error “Unexpected error occurred. Detailed traceback information available in file /var/log/kaspersky/ksmg/traceback-[number].txt»:
Preparing application...
Select the language for viewing the End User License Agreement, Privacy Policy, and the Default Protection Settings Notice.
...
Specify IP address of the current node
The IP address will be used to communicate with other nodes [198.51.100.2]:
>
Specify the port number of the current node
The port number will be used to communicate with other nodes [9045]:
>
Unexpected error occurred. Detailed traceback information available in file /var/log/kaspersky/ksmg/traceback-[number].txt
Events from the /var/log/kaspersky/ksmg/traceback-[number].txt log terminate with the error:
_socket.socket.__init__(self, family, type, proto, fileno)
OSError: [Errno 97] Address family not supported by protocol
Cause
Kaspersky Secure Mail Gateway requires the IPv6 protocol support, but IPv6 is disabled at the kernel level of the operating system.
To make sure that this is the cause of the problem, check the ipv6.disable parameter in one of the following ways:
- To check the parameter in the message buffer of the kernel, run the following command in the device terminal:
dmesg | grep ipv6
- To check the parameter in a report collected by the collect.sh script, open the /collect/logs/dmesg.txt file and find the strings containing IPv6.
The 1 value of the ipv6.disable parameter indicates that IPv6 is disabled in the kernel boot settings.
Example:
[ 0.023813] Kernel command line: BOOT_IMAGE=/vmlinuz-5.15.0-107-generic root=/dev/mapper/ubuntu--vg-ubuntu--lv ro quiet splash ipv6.disable=1
Solution
Enable IPv6 in the kernel boot settings of the operating system using the manufacturer's instructions for your OS version.
If you need to exclude IPv6 network communication, you can disable IPv6:
- Through the operating system settings according to the manufacturer’s instructions for your OS version.
- In the mail server configuration according to the manufacturer's instructions.
What to do if the issue persists
If the issue persists, submit a request to Kaspersky Technical Support via Kaspersky CompanyAccount. Attach a screenshot of the error and a report generated with the collect.sh script.