Error 0x80004005 “Fatal error during installation” occurs upon disabling Windows Defender
Show applications and versions that this article concerns
- Kaspersky Endpoint Security 12.6 for Windows (version 12.6.0.438)
- Kaspersky Endpoint Security 12.5 for Windows (version 12.5.0.539)
- Kaspersky Endpoint Security 12.4 for Windows (version 12.4.0.467)
- Kaspersky Endpoint Security 12.3 for Windows (version 12.3.0.493)
- Kaspersky Endpoint Security 12.2 for Windows (version 12.2.0.462)
- Kaspersky Endpoint Security 12.1 for Windows (version 12.1.0.506)
- Kaspersky Endpoint Security 12 for Windows (version 12.0.0.465)
- Kaspersky Endpoint Security 11.11 for Windows (version 11.11.0.452)
- Kaspersky Endpoint Security 11.10 for Windows (version 11.10.0.399)
- Kaspersky Endpoint Security 11.9 for Windows (version 11.9.0.351)
- Kaspersky Endpoint Security 11.8 for Windows (version 11.8.0.384)
- Kaspersky Endpoint Security 11.7 for Windows (version 11.7.0.669)
Issue
Fatal error during installation may occur when you are installing Kaspersky Endpoint Security.
In the installation logs, you will get the following lines:
DisableWindowsDefender: Failed to access local group policy. Error 0x80004005.
DisableWindowsDefender: DisableWindowsDefender: finished. Return value 1603.
Cause
The installer of Kaspersky Endpoint Security calls the OpenLocalMachineGPO(GPO_OPEN_LOAD_REGISTRY) function and assigns aits local group policy which allows disabling Windows Defender and configuring the settings required for installation. If disabling Windows Defender on a target host is blocked by by the domain policy, the error occurs.
Solution
- Apply the GPO (Group Policy Object) policy with default settings — Default Domain Policy,where all Windows Defender have the Not configured value, on the target host.
- Force apply the group policies on target hosts.
- Restart the computer.
- Try to install the application once again.
What to do if the solution did not help
If the solution above did not help:
- Temporarily move the host out of the Active Directory domain.
- Reset local group policies.
- Try to install the application once again.
- After successful installation, return the host to the Active Directory domain.
If the issue persists, collect the diagnostic data and submit a request to Kaspersky Technical Support via Kaspersky CompanyAccount.