Kaspersky Total Security 20
 
 

Network connection error. DNS issue

Latest update: July 11, 2023 ID: 13771
 
 
 
 

Cause

  • Incorrect date set on a computer.
  • DNS client service does not work on your computer.
  • DNS server malfunction on your Internet services provider’s side.

Solution

  • Check the system date on your computer. See this article for instructions.
  • Make sure that DNS client service works correctly. If the service is not running, restart it. See the guide below.
  • If the DNS client service is working, but the issue persists, try entering the address of a different DNS server in the network settings. See the guide below.
 
 
 
 

How to restart the DNS client

 
 
 
 

How to change the DNS address in the network settings

 
 
 
 

What to do if the issue persists

 
 
 
 
 
Did you find this article helpful?
What can we do better?
Thank you for your feedback! You're helping us improve.
Thank you for your feedback! You're helping us improve.