“Fatal error during installation” occurs upon disabling Windows Defender
This article concerns:
- Kaspersky Endpoint Security 11.7.0 for Windows (version 11.7.0.669)
- Kaspersky Endpoint Security 11.6.0 for Windows (version 11.6.0.394)
- Kaspersky Endpoint Security 11.5.0 for Windows (version 11.5.0.590)
- Kaspersky Endpoint Security 11.4.0 for Windows (version 11.4.0.233)
- Kaspersky Endpoint Security 11.3.0 for Windows (version 11.3.0.773)
- Kaspersky Endpoint Security 11.2.0 for Windows (version 11.2.0.2254)
- Kaspersky Endpoint Security 11.1.1 for Windows (version 11.1.1.126)
- Kaspersky Endpoint Security 11.1.0 for Windows (version 11.1.0.15919)
- Kaspersky Endpoint Security 11.0.1 for Windows (version 11.0.1.90)
- Kaspersky Endpoint Security 11.0.0 for Windows (version 11.0.0.6499)
- Kaspersky Endpoint Security 10 Service Pack 2 Maintenance Release 4 (version 10.3.3.304)
- Kaspersky Endpoint Security 10 Service Pack 2 Maintenance Release 3 (version 10.3.3.275)
- Kaspersky Endpoint Security 10 Service Pack 2 Maintenance Release 2 (version 10.3.0.6294)
- Kaspersky Endpoint Security 10 Service Pack 1 Maintenance Release 4 (version 10.2.6.3733)
Issue
Fatal error during installation may occur when you are installing Kaspersky Endpoint Security.
In the installation logs, you will get the following lines:
DisableWindowsDefender: Failed to access local group policy. Error 0x80004005.
DisableWindowsDefender: DisableWindowsDefender: finished. Return value 1603.
Cause
The installer of Kaspersky Endpoint Security calls the OpenLocalMachineGPO(GPO_OPEN_LOAD_REGISTRY) function and assigns aits local group policy which allows disabling Windows Defender and configuring the settings required for installation. If disabling Windows Defender on a target host is blocked by by the domain policy, the error occurs.
Solution
- Apply the GPO (Group Policy Object) policy with default settings — Default Domain Policy,where all Windows Defender have the Not configured value, on the target host.
- Force apply the group policies on target hosts.
- Restart the computer.
- Try to install the application once again.
What to do if the solution did not help
If the solution above did not help:
- Temporarily move the host out of the Active Directory domain.
- Reset local group policies.
- Try to install the application once again.
- After successful installation, return the host to the Active Directory domain.
If the issue persists, submit a request to Kaspersky technical support via Kaspersky CompanyAccount. Please include a detailed description of the issue. Before contacting the support, see the guide on creating a request in the knowledge base.