Error “Upgrade to the new version of Kaspersky Endpoint Security is not available because the computer is connected to an untrusted Kaspersky Security Center”
Latest update: 1 August 2024
ID: 16078
This article concerns Kaspersky Endpoint Security 12.6 for Windows (version 12.6.0.438).
Issue
When upgrading Kaspersky Endpoint Security for Windows to a new version, the error “Upgrade to the new version of Kaspersky Endpoint Security is not available because the computer is connected to an untrusted Kaspersky Security Center” may occur.
Cause
The error may occur in the following cases:
- The device on which Kaspersky Endpoint Security for Windows is being updated has been moved from the old Administration Server [KSC1] to the new one [KSC2], and the connection security password has not been updated on the new Administration Server.
- The device is connected to the current Administration Server by mistake.
In both cases, the Administration Server to which the device is connected will be considered untrusted, and upgrading to a new version of Kaspersky Endpoint Security for Windows will be restricted for security reasons.
Solution
- Reconnect the device to a new Administration Server: follow step 2 of the Reconnecting the computer to a different Administration Server section.
- Try upgrading Kaspersky Endpoint Security for Windows to a new version again.
If you don’t remember the current password for the Administration Server connection protection task on the old Administration Server [KSC1], but remember the Kaspersky Endpoint Security for Windows management protection password, you can reset the forgotten password. To do so, either disable the Administration Server connection protection, or remove and reinstall Kaspersky Endpoint Security for Windows. Then run the connection protection for the new Administration Server [KSC2].