Issue when updating Kaspersky Security for Virtualization Light Agent using Citrix App Layering and a full user layer

 

Kaspersky Security for Virtualization 5.x Light Agent

 
 
 

Issue when updating Kaspersky Security for Virtualization Light Agent using Citrix App Layering and a full user layer

Back to "Troubleshooting"
Latest update: June 04, 2021 ID: 15611
 
 
 
 
The article concerns Kaspersky Security for Virtualization 5.0 Light Agent.
 
 
 
 

Issue

When you upgrade Kaspersky Security for Virtualization Light Agent to version 5.1 that is used together with Citrix App Layering and a full user layer, you may still have folders, files and registry keys from the previous version of the application on your computer.

Cause

Citrix recommendations to install the antivirus application on the template with a full user layer have not been implemented. The full user layer logs all changes currently occurring on the virtual machine.

Solution

  1. The template with the new version of the application must include the AlwaysOnBoot multi-line parameter in the HKLM\SYSTEM\CurrentControlSet\Services\unifltr\ key. Add the following folders as key parameters:
    • C:\ProgramData\KasperskyLab\
    • C:\ProgramData\Kaspersky Lab\
    • C:\Program Files(x86)\Kaspersky Lab\
    This key must be on the layer where the KLNagent Network Agent and Kaspersky Security for Virtualization Light Agent are installed. Using the AlwaysOnBoot key is a Citrix workaround. It is neither officially tested nor supported.
  2. Restore the user layers. For instructions, see the Citrix documentation.

To learn more about installing antivirus applications, see this page of Citrix documentation.

 
 
 
 
Was this information helpful?
Yes No
Thank you
 

 
 

How can we improve this article?

Your feedback will be used for content improvement purposes only. If you need assistance, please contact technical support.

Submit Submit

Thank you for your feedback!

Your suggestions will help improve this article.

OK