Verification of a recipient's email digital signature fails when using Kaspersky Security 8.0 for Linux Mail Server

Latest update: April 28, 2023 ID: 12485
 
 
 
 

Issue

Emails with digital signatures processed by Kaspersky Secure Mail Gateway may not pass the verification of the recipient.

Cause

The signature verification fails because of the X-KLMS-AntiVirus-Status header in the MIME part of the message.

Solution

Turn off adding titles to all parts of the email using the allowXHeadersForParts = 0 parameter and confirm adding general titles:

# /opt/kaspersky/klms/bin/klms-control --get-settings 3 | grep X

<addXHeaders>1</addXHeaders>

<allowXHeadersForParts>0</allowXHeadersForParts>

What to do if the issue persists

If the issue persists, submit a request to Kaspersky technical support via Kaspersky CompanyAccount. Please include a detailed description of the issue. Before contacting the support, see the guide on creating a request in the Knowledge Base.

 
 
 
 
 
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